osCommerce broken after PHP/MySQL 5upgrade

osCommerce doesn’t seem to be very compatible with MySQL 5 and will most likely generate a load of errors from its SQL statements. Upgrading to the latest version is recommended and should fix this.  For heavily modified versions this may not be posible and will require some hacking to fix:

add () to from tables in all queries in all code (usually in includes includes/???) i.e from table1,table2 becomes from (table1,table2)
add auto_increment to tables where it is not entered on the primary key i.e banner_history

register_long_arrays and register_globals need to be enabled in php.ini

You can leave a response, or trackback from your own site.

Leave a Reply