Spamassassin 2010 bug

A bit of an oversight – old versions of Spamassassin have an inbuilt rule to block emails with a future date.  Not a bad idea really, but the rule starts blocking things from 2010!  The rule should be fixed in newer versions, however Plesk for example uses a fairly old version. You can edit the rule in /usr/share/spamassassin/72_active.cf

##{ FH_DATE_PAST_20XX
header   FH_DATE_PAST_20XX      Date =~ /20[1-9][0-9]/ [if-unset: 2006]
describe FH_DATE_PAST_20XX      The date is grossly in the future.
##} FH_DATE_PAST_20XX

Probably a good idea to set it to something like Date =~ /20[2-9][0-9] .  By 2020 I imagine this server won’t be alive!

You can leave a response, or trackback from your own site.

Leave a Reply